Issues with Hiragana lyrics, USTs, and plugins

Discussion in 'UtaHelp' started by ShaddupWesley, May 7, 2018.

  1. ShaddupWesley

    ShaddupWesley Momo's Minion

    Messages
    3
    Likes Received
    2
    Trophy Points
    7
    Hi everyone! Hopefully someone here can help me, because I'm at a total loss >.< I'm having a few different issues regarding using hiragana characters in UTAU.
    Background info: Before I installed UTAU, voicebanks, and plugins, I changed my system locale to Japan and downloaded the Japanese language pack, and enabled the IME keyboard. I'm running Windows 10, and I have the English version/patch for UTAU. I downloaded and use the Kaikai Kim voicebank and it works perfectly with both hiragana and romaji USTs.

    The problems:
    1) I'm trying to make my own voicebank; the .wav files currently saved are saved as romaji (a, i, o, u, i), and the voicebank works fine when I input notes in those romaji syllables. However, I want to be able to use this voicebank with hiragana USTs, not just romaji, so I tried to add aliases to each sound--however, when I copy and paste a hiragana character into the space, or when I input a character using my Japanese keyboard, they simply turn into question marks.
    Screenshots
    2) When trying to input hiragana lyrics, the same issue occurs--they just turn to question marks. Although, sometimes, the note just disappears altogether.
    Screenshots 2
    3) Another issue is with plugins; I've successfully downloaded the plugin romatokana without any issues. However, when I tried to download a plugin that was all in Japanese, the characters that downloaded are all messed up and I'm not 100% that the plugin in working (though, granted, I'm not 100% sure how to use it yet).
    4) Downloading voicebanks--same as above! >.< Though my system locale is Japanese, some voicebanks aren't downloading properly and I can't use them because the characters are all messed up and weird.
    Screenshots 3 + 4
    Whew! Okay, sorry if that's a lot, I tried to be as detailed as possible. I've been trying to find a solution to this but I simply haven't found anything--everyone just seems to say to change my system locale to Japanese and redownload UTAU, but my system locale is already set to Japanese and has been from the start, so what else can I try? Thank you!
     
  2.  
  3. Kiyoteru

    Kiyoteru Local Sensei Supporter Defender of Defoko

    Messages
    2,593
    Likes Received
    3,503
    Trophy Points
    157
    Are you using the default system utility to unzip files? Just to be sure that the text encoding is staying intact in the unzipping process, try using 7zip.
    https://www.7-zip.org/
     
  4. ShaddupWesley

    ShaddupWesley Momo's Minion

    Messages
    3
    Likes Received
    2
    Trophy Points
    7
    I'm using winzip, but I'd definitely be willing to try a different utility; I'm not totally sure if that's the problem though, because the text in the zipped file is already messed up before I unzip it. As in, when I open it with winzip and I'm looking at everything in the winzip window, before extracting it, the text is already "mojibake" (as I've seen it called). Do you think trying a different utility would help that?
     
  5. Sors

    Sors Meiji Master Tutor Defender of Defoko

    Messages
    640
    Likes Received
    550
    Trophy Points
    123
    Are you sure you changed your LOCALE and not your Location to japanese? Its a common mistake, and might explain why you still get mojibake. What Windows version do you have?
     
    ShaddupWesley likes this.
  6. partial

    partial UTAU English advocate Global Mod Supporter Defender of Defoko

    Messages
    1,486
    Likes Received
    2,709
    Trophy Points
    138
    They mentioned they're running Win10 in the op.

    I agree with what Sors has said here. Just to be absolutely sure you've changed your locale (which it sounds like you haven't if files are in mojibake before you even extract them), here are the steps to do so.

    1. Click Start, then Control Panel
    2. Click Clock, Language and Region
    3. Click Region
      The Region and Language options dialog appears.
    4. Click the Administrative tab
    5. Under the Language for non-Unicode programs section, click Change system locale and select the desired language.
    6. Click OK
    7. Restart the computer to apply the change.
    You will need to redownload UTAU and any Japanese-encoded (hiragana wav files) voicebanks after changing your locale.
     
    ShaddupWesley likes this.
  7. Kiyoteru

    Kiyoteru Local Sensei Supporter Defender of Defoko

    Messages
    2,593
    Likes Received
    3,503
    Trophy Points
    157
    I haven't verified this for myself in my Windows VM, but I certainly would suggest giving it a try. It's a common fix for mojibake on Mac.
     
  8. ShaddupWesley

    ShaddupWesley Momo's Minion

    Messages
    3
    Likes Received
    2
    Trophy Points
    7
    Okay wow.... I feel really dumb now, I didn't do the locale thing correctly :blink:Thank you so much! I'm sorry my problem was so easily fixed, I really appreciate you taking the time to help me out though! I had only changed my 'region' to Japan :cynical:
     
    partial and Kiyoteru like this.
  9. partial

    partial UTAU English advocate Global Mod Supporter Defender of Defoko

    Messages
    1,486
    Likes Received
    2,709
    Trophy Points
    138
    I'm glad things worked out. Happy UTAUing!
     
    Kiyoteru likes this.

Share This Page