Prefix map for multipitch English not working ?

Discussion in 'Q&A and Tech Support' started by HoneyPai, Dec 26, 2016.

  1. HoneyPai

    HoneyPai Defoko's Slaves Defender of Defoko

    Messages
    376
    Likes Received
    1,054
    Trophy Points
    123
    Hello! I'm currently not on my computer so I can't really show screenshots right now
    But I recorded a 4 pitch vccv English vb, and tried to test what I had, now the bank isn't done so there are sounds missing, but the prefix map will not work for the sounds that I do have done, it will only partially work if I put the pitch names under suffix, but even then, it won't completely work, I had no issue with this the last time I made a tripitch English, any solution suggestions?

    Also yes, btw, I do know how to make a prefix map.
     
  2.  
    6_Jpop CDJapan
  3. Mougeki Mero

    Mougeki Mero Defoko's Slaves Defender of Defoko

    Messages
    438
    Likes Received
    1,175
    Trophy Points
    122
    This is weird...I kean theybshould either fully work or not work at all, but you say they are partially working...

    I dont think I can help much besides telling you to check the obvious things...Hopefully it is one of these things:

    ~is the prefixmap file located in the root of your UTAU folder?
    ~Does the pitches are separated in different folders?
    ~Try putting the pitches names as prefix? Once UTAU messed up for me on my old pc and even if I wrote a suffix it worked only mapped as prefix XD

    On a side note, which method you use? 1 misc. pitch without suffix and other pitches with suffix or are all the pitches suffixed? If you used the 1st method try switchinh to the second...
     
    HoneyPai likes this.
  4. HoneyPai

    HoneyPai Defoko's Slaves Defender of Defoko

    Messages
    376
    Likes Received
    1,054
    Trophy Points
    123
    All already done as it should be
    All pitches are correctly in their pitch folders as well as the aliases matching the pitches. All pitches are suffixed, like I said, I tried putting all pitches on both prefix and suffix but nothing worked, I've never had this issue and I no the sounds aren't missing because they work when I put the pitch name in manually
     
    Mougeki Mero likes this.
  5. Mougeki Mero

    Mougeki Mero Defoko's Slaves Defender of Defoko

    Messages
    438
    Likes Received
    1,175
    Trophy Points
    122
    Could you send me part of the VB? Like the needed files for it to load and 3 samples of each pitch? Not that I can do anything but I'd like to try...
     
  6. HoneyPai

    HoneyPai Defoko's Slaves Defender of Defoko

    Messages
    376
    Likes Received
    1,054
    Trophy Points
    123
    Amm I'm not sure if I could send you part of the vb, as it's pretty big, but I can provide screenshots as of now
    So I have the prefix map set up as you can see and then the ust
    You can see I already had to type E4 after some of the lyrics already
    But then if you look at "I" you can see nothing but I, no (B4) or anything, I open it in the oto, nothing comes up for "IB4" but then when I type it into the lyric, the sound appears
    [​IMG]
     
    Mougeki Mero likes this.
  7. Mougeki Mero

    Mougeki Mero Defoko's Slaves Defender of Defoko

    Messages
    438
    Likes Received
    1,175
    Trophy Points
    122
    Uhm, that is really strange...Everything is just perfect...Oh, did you used a pre made oto? Or copy-pasted the aliases? Sometimes some letters are font (or encoding)-different from your PC's...Try copying the "B4" from the oto and pasting this "B4" into the prrfix.map

    I actually doubt this is the problem, but there's a chance it could be...
    --- Double Post Merged, Dec 26, 2016 ---
    Also tjis is actually for Mac. But try either having both a prefixmap and prefix.map files in your folder. Or only a prefixmap (without the dot)...There is a chance it works...
     
    HoneyPai likes this.
  8. HoneyPai

    HoneyPai Defoko's Slaves Defender of Defoko

    Messages
    376
    Likes Received
    1,054
    Trophy Points
    123
    I did not copy and paste the aliases but I did use a premade oto, but that didn't give me issues on my last multipitch English attempt
     
    Mougeki Mero likes this.
  9. Mougeki Mero

    Mougeki Mero Defoko's Slaves Defender of Defoko

    Messages
    438
    Likes Received
    1,175
    Trophy Points
    122
    That is just strange...I have no ideas anymore...I maded a prefix.map using note pad...Hopefully it will work >< https://www.dropbox.com/s/wg6mg0kjt9zthxs/prefix.map?dl=0

    EDIT: If this one somehow glitches try opening it in notepad and saving as UTF-8 encoding...Then rename it to "prefix.map" again
     

Share This Page