UTAU installation does not work correctly

Discussion in 'UtaHelp' started by UtaNatsuk0, Sep 30, 2018.

  1. UtaNatsuk0

    UtaNatsuk0 Momo's Minion

    Messages
    2
    Likes Received
    1
    Trophy Points
    4
    I have installed UTAU multiple times by now, wiping everything clean. No matter what I do, it just won't work. The interface is in English, although everything else is just gibberish.

    Here is what I have tried, with restarting between steps and wiping clean folders of any traces before and after reinstalls:

    - Set Locale to Japanese and installed Japanese language pack.
    - Reinstalled UTAU 0.4.18e from zip. (about 3 times because I thought I messed up)
    - Unblocking installation before extracting the file
    - Turning off Windows Defender while downloading and installing.
    - Run UTAU as Admin
    - Giving Full Control to all Users (since this is my own personal PC)
    - Using tutorials on Youtube, this forum and other places on the net.
    - Trying to troubleshoot it myself.
    - Running it in Windows 8 and Windows 7 Compatibility mode.
    - Shutting down computer and starting it up again in place of restarting.
    - Installing UTAU somewhere else instead of the program files folder.

    What happens is that the program looks fine, although when I try to put a note with the pen, it turns into a question mark. When I try to manually put in a note like say, "が" (ga), it turns into "?", sometimes "??". I can add romaji fine, but nonetheless, a note won't play.

    I have a Windows 10 64-Bit OS with Windows 10 Home Edition, 1803 Version. Unless Windows messed with the permissions, I haven't changed anything unless stated above.

    Any kind of recommendation is welcome, I never had this issue before I started using Windows 10, on a clean install nonetheless. I will provide screenshots if necessary.
     
  2.  
  3. Kiyoteru

    Kiyoteru Local Sensei Supporter Defender of Defoko

    Messages
    2,630
    Likes Received
    3,530
    Trophy Points
    157
    Did you redownload the UTAU installer after changing locale to Japanese?
     
  4. UtaNatsuk0

    UtaNatsuk0 Momo's Minion

    Messages
    2
    Likes Received
    1
    Trophy Points
    4
    Yes I did. I found the culprit and it was something I didn't see in a tutorial except one I watched after I did it myself:

    In the Control Panel in "Clock and Region", when I clicked on "Change Location", I clicked on "Administrative" out of curiousity. It showed me a thing that said: "Language for non-Unicode programs" and it was set to my install language, which was german. I set it to Japanese and restarted my computer, just for good measure.

    When I loaded back into UTAU, everything work and shows up fine like it should.

    Nonetheless, it's something I didn't see that error I made since this is my first time installing UTAU on Windows 10 and I haven't had to do this on my previous system (Windows 7).
     
    partial likes this.
  5. Kiyoteru

    Kiyoteru Local Sensei Supporter Defender of Defoko

    Messages
    2,630
    Likes Received
    3,530
    Trophy Points
    157
    This process is called "changing the locale".
     
  6. Reson_Lore

    Reson_Lore Lord Of Edge Defender of Defoko

    Messages
    103
    Likes Received
    35
    Trophy Points
    38
    As for the note becoming ??, now that you have Japanese locale set, there will be a button on your taskbar, between the arrow for the icon menu and the Action Centre. For me personally, it says ENG at the moment, but it will say the language you have set for the computer. If you click on it, Japanese will be a second option (I also have Chinese for NIAONiao). Click on it and try inputting the text again. It should work now that you have the Japanese keyboard set and Windows can read the symbols.
     

Share This Page