UTAU Locale Issue

Discussion in 'UtaHelp' started by Bekah, Feb 8, 2019.

  1. Bekah

    Bekah Momo's Minion

    Messages
    9
    Likes Received
    2
    Trophy Points
    4
    Yes, I know, I know. I'm supposed to change the system locale to Japanese before installing UTAU. I was too eager to install it on my new computer and forgot all about that, though.

    So I changed the locale to Japanese, restarted my computer, uninstalled UTAU, redownloaded it, and reinstalled it. It's still showing a huge mess of mojibake and my computer is still downloading voicebanks with the hiragana changed to mojibake.

    Any ideas on how to fix this?
     
  2.  
    6_Jpop CDJapan
  3. WyndReed

    WyndReed Dareka tasukete! Global Mod Defender of Defoko

    Messages
    140
    Likes Received
    989
    Trophy Points
    98
    What OS are you using?
     
  4. Bekah

    Bekah Momo's Minion

    Messages
    9
    Likes Received
    2
    Trophy Points
    4
    I'm using Windows 10
     
  5. WyndReed

    WyndReed Dareka tasukete! Global Mod Defender of Defoko

    Messages
    140
    Likes Received
    989
    Trophy Points
    98
    Is your region format set so that the decimal symbol is a period and not a comma? There are screenshots of what that sould look like in this thread.
     
  6. Kiyoteru

    Kiyoteru Local Sensei Supporter Defender of Defoko

    Messages
    2,717
    Likes Received
    3,614
    Trophy Points
    157
    Please show us where exactly you changed locale as well. There are many cases of people thinking they have changed the locale to Japanese when in fact they have actually changed a similar-sounding setting. You need to make sure that the language/encoding for non-Unicode programs is Japanese.
     
  7. Bekah

    Bekah Momo's Minion

    Messages
    9
    Likes Received
    2
    Trophy Points
    4
    Yes, it is. It's set exactly like that.

    I went to the Region settings and went to the Administrative tab and changed the locale to Japanese, just like on every tutorial I've seen.
     
  8. Lucas Campbell

    Lucas Campbell Momo's Minion

    Messages
    3
    Likes Received
    2
    Trophy Points
    8
    --

    Thank god I have found a thread that could (possibly) help me with this problem, I am having the exact same issue. Same OS and everything, I have really tried to get UTAU working without any mojibake.

    I hope you find a way to fix it!
     
  9. Bekah

    Bekah Momo's Minion

    Messages
    9
    Likes Received
    2
    Trophy Points
    4
    Is your computer also downloading voicebanks and stuff with mojibake in the file names and oto.ini? The problem seems to be universal and not just on UTAU. So despite having a Japanese locale, it's replacing EVERYTHING that's Japanese with mojibake.
     
  10. WyndReed

    WyndReed Dareka tasukete! Global Mod Defender of Defoko

    Messages
    140
    Likes Received
    989
    Trophy Points
    98
    Do you have the japanese language keyboard installed?
     
  11. Bekah

    Bekah Momo's Minion

    Messages
    9
    Likes Received
    2
    Trophy Points
    4
    Yes, I do. It'll show Japanese text, but no Japanese in file names and programs and such.
     
  12. Lucas Campbell

    Lucas Campbell Momo's Minion

    Messages
    3
    Likes Received
    2
    Trophy Points
    8
    --

    Yes! That's exactly my problem, it upsets me a lot that I can't find a solution for it! :ehhh:
     
  13. Bekah

    Bekah Momo's Minion

    Messages
    9
    Likes Received
    2
    Trophy Points
    4
    I hate to just bump this thread, but does anyone have any idea on how I could fix this? Windows 10 just seems to refuse to display Japanese in general, unless it's in text on a web page for example.
     
  14. susrever

    susrever Teto's Territory Defender of Defoko

    Messages
    28
    Likes Received
    91
    Trophy Points
    23
    Do you have admin rights on the account you are using to set the locale? Also, are you sure you restarted your PC and not just shut it down after changing? I think it might be worth trying to set it back to the original locale / restart / and setting it to japanese again, if you haven't done it already
     
  15. Bekah

    Bekah Momo's Minion

    Messages
    9
    Likes Received
    2
    Trophy Points
    4
    I have admin rights and I did restart it. I haven't tried changing it back to English, restarting, changing it to Japanese, and restarting again yet though, so I'll try that out. I'll update on whether that works or not when I do that. :wink:
    --- Double Post Merged, Feb 12, 2019, Original Post Date: Feb 12, 2019 ---
    That worked out well! I think an issue was that "Beta: Use Unicode UTF-8 for worldwide language support" was checked. So to anyone having this same problem: When changing the locale, make sure that's not checked!
     
    susrever and Kiyoteru like this.

Share This Page