Faulty Voicebank sample causing UTAU to crash

FuzzyMitten

Momo's Minion
Hi, I'm new here!
I do know some little stuff on how to use UTAU and made a simple CV voicebank, that's pretty much it.


Background:
Recently I decided to create an UTAU voicebank voiced by my close friend, all necessary CV samples have been recorded and then cleaned after. The goal was to imitate Pico from FNF so the samples were filtered using audacity, then oto'ed everything properly as much as I can.

Problem:
The majority of the samples generated sound horrible, and some did not produce any sound at all which I expected. But what I didn't expect was UTAU to crash during rendering 'ru'.

Attempt:
I tried to clean and rerun the problematic sample to the filter again with minor tweaking (formant & volume) and regenerate the frq but UTAU crashes on it.
Changing alias produces the same result.

Note:
Rerecording is not an option since the voice provider is not present and unable to for the next 2 weeks.
Using a sample from my voice is also not an option since my voice is way squeakier than my friend's. (tried it and it's very different)

So... currently facing a roadblock. Any help is greatly appreciated! :love:
 

Thehyami

Ruko's Ruffians
Defender of Defoko
It'd be helpful If you could share the voicebank so we could take a look at it
 

FuzzyMitten

Momo's Minion
Thread starter
Here's the voicebank Pico - A0.0.5 tho I have to remove it after 12hrs cause I'll be in a lot of trouble if this gets distributed before it's completed. You can look at the wip.txt if that helps.
 

Thehyami

Ruko's Ruffians
Defender of Defoko
Okay so there are a few things I want to address:

1. Your voicebank is not CV, it is VCV.

2. You haven't recorded all necessary samples, that's why some do not produce sound at all.
You don't have "ba", "be", "ra", etc. This includes "ru", you have not recorded this.

3. You removed the lower frequency part of the audio when filtering the audio. So you left with the formants.
This lower frequency part is where the base pitch exist.
When you removed this part, the frq generator will suffer, because what they do is tracking the base pitch.

My suggestion:

1. Get an actual full CV reclist.
Record the full CV voicebank,
and do the filtering after you rendered the song out of utau.
Not on the samples itself.

2. You can use the g flag to make your voice deeper.
 

Halo

Icon by Wanpuccino @ DA
Administrator
Defender of Defoko
If you want to patch the vb in a pinch, you can replace ru with どぅ/du. I think maybe your upload wasn't the whole bank or something, since you said you have the file and re-edited it... but what you've sent over definitely only has some samples, and it *is* VCV.

All I can suggest without having access to the file is play with other resamplers, and edit the whole bank with frqeditor to see if you can artificially re-normalise the frqs back into a usable state (I don't really think it'll work due to what Thehyami said, but the idea of keeping the effects in-back is appealing so it's worth a try...)

Also, for troubleshooting maybe try the un-edited sample in UTAU and see if that works. if it still breaks it then you know something is really up with the actual sample or the oto maybe??
 

FuzzyMitten

Momo's Minion
Thread starter
Okay so there are a few things I want to address:
1. Your voicebank is not CV, it is VCV.
Oh, apologies for the confusion as I was aiming for it to be able to be used as both CV and VCV. Prioritizing the VCV first.

2. You haven't recorded all necessary samples, that's why some do not produce sound at all.
You don't have "ba", "be", "ra", etc. This includes "ru", you have not recorded this.
All samples have been recorded but not all have been filtered (72 samples have been filtered) since I still have to re-time the samples to match a reference oto.ini
Sorry for it as I have forgotten to mention this.

3. You removed the lower frequency part of the audio when filtering the audio. So you left with the formants.
This lower frequency part is where the base pitch exist.
When you removed this part, the frq generator will suffer, because what they do is tracking the base pitch.
I DID NOT KNOW THIS:holy:
Guess that's why it's so jumpy and out of tune and moresampler absolutely hates it.
As to why the lower frequency is missing, the filter (frequencyshifter) intentionally removes the lower frequency since I was following a 'considered' official guide.

My suggestion:

1. Get an actual full CV reclist.
Record the full CV voicebank,
I was aiming for it to be able to be used as both CV and VCV, but If gets it to work properly, it won't hurt to redo it.

and do the filtering after you rendered the song out of utau.
Not on the samples itself.
2. You can use the g flag to make your voice deeper.
I tried doing this before applying the filter but it doesn't sound the way I want it to be...

Thank you for the help and suggestion!:love:
 

FuzzyMitten

Momo's Minion
Thread starter
If you want to patch the vb in a pinch, you can replace ru with どぅ/du. I think maybe your upload wasn't the whole bank or something, since you said you have the file and re-edited it... but what you've sent over definitely only has some samples, and it *is* VCV.
I was aiming only for it just to be CV voicebank but the voice provider went the extra mile.

I think maybe your upload wasn't the whole bank or something
Yes, It's not the whole bank as only 72 samples have been filtered. (74 at the time of this reply)

All I can suggest without having access to the file is play with other resamplers, and edit the whole bank with frqeditor to see if you can artificially re-normalise the frqs back into a usable state (I don't really think it'll work due to what Thehyami said, but the idea of keeping the effects in-back is appealing so it's worth a try...)
I was hoping to avoid this as much as possible... manually editing the frq only to be used with resamplers that use it... ah... :bigtears:

edit the whole bank with frqeditor
I took a look at it and I am questioning why have I not known this before and why is this not built into UTAU itself.

Also, for troubleshooting maybe try the un-edited sample in UTAU and see if that works. if it still breaks it then you know something is really up with the actual sample or the oto maybe??
The unfiltered samples (oto'ed by moresampler) work normally, minus the jitters.
the oto doesn't seem to be the culprit when looked at under setParam, I'll do a minor readjustment if that works.
I was leaning on that it may be a bad export from audacity, tho it was 7th time it got re-exported.
I'll try exporting the samples from another program if that works...


Thank you for the suggestion and help!! :love:
 

Thehyami

Ruko's Ruffians
Defender of Defoko
You're welcome! Or you could try doing the filtering after you generate the oto and the frq files
 

Similar threads