Invalid procedure call or argument?


Momo's Minion
So I've just got a new laptop with Windows 10, and attempted to install UTAU. The first time I installed the app, I forgot to set Japanese as the locale so deleted and tried again with the correct locale. Problem is, I got this error. I deleted the files and reinstalled the setup wizard to try again, same thing. I've tried every trick in the book: changed the resampler, ran as administrator, restarted my laptop after double checking the locale, moving it to different folders, won't budge.

Upon looking more closely when reinstalling the setup wizard, I think I might know what the problem is. When I reinstalled the setup wizard a second time, it asked me if i wanted to repair or delete UTAU instead of installing it for the first time. Though when I tried to uninstall UTAU, both with the UTAU setup wizard and Windows itself, it gave me an error saying the app was unable to install.

My theory is that my laptop thinks UTAU still exists somewhere on my laptop but that there's also something missing that prevents it from running. I might try a factory reset as a last resort, but any other advice would be appreciated. I managed to install UTAU successfully about a year and a half ago on an old Windows 7 laptop, so am pretty familiar with how to install UTAU, but this has me stumped. Thank you for any help! :smile:


  • 2023-04-15.png
    193.2 KB · Views: 4
  • 2023-04-15 (1).png
    2023-04-15 (1).png
    200.6 KB · Views: 5
  • 2023-04-15 (2).png
    2023-04-15 (2).png
    178.4 KB · Views: 5


Momo's Minion
Thread starter
SOLVED! I removed the retail demo settings on my laptop and reinstalled UTAU and it works now, laptop doesn't seem to like UST files. I'll save them in UTAU, but they won't show up in the folder I save them to. I can use the Open function in UTAU to see them and open them, but then they're always silent, even though the resampler renders them correctly. It's so strange. I reinstalled UTAU from scratch after encountering this problem, only for it to persist. Can anyone help?


Icon by Wanpuccino @ DA
Defender of Defoko
What folder are you saving them to, where is it located on your PC? And additionally, are you running as administrator?


Momo's Minion
Thread starter
Thank you for the response! Currently it's in Program Files (x86). I have tried moving it to other places, like Documents and Program Files, but to no avail. Running as administrator doesn't do anything either. As soon as I save a file as a UST, when I try to render it again, it all comes out as silent. The UST file doesn't show up in my explorer either.
Post automatically merged:

WAIT I figured it out! The permissions for the 86 folder were weird AF - my USTs and WAV files weren't saving to the x86 folder at all, they were going to my user app data folder for some weird reason. That's why I couldn't find them. Anyway, UTAU now lives in documents and all my lost UST files were found and moved there. Peace and love on Planet Earth!
Last edited:
  • Like
Reactions: Halo

Similar threads