(FIXED) UTAU won't sing USTs

rainydaze

Momo's Minion
Both the UST and the voicebank are VCV so I don't know what the problem could be :sad:
 
Last edited:

Ibis

Momo's Minion
If you are absolutely sure that your UST and voicebank are of the same type, then these are the only things I could think of at the moment:

What language is your UST in? If you UST uses romaji and your voicebank can only read Hiragana, or vica versa, your Utau won't be able to read it and therefore won't make any sound. To check what language your voicebank can read, you can go into their voice files. If your voicebank's wav files are titled with symbols like "あ", or "か", that is hiragana. If the tiles are more like "a" or "ka", that is romaji. If your UST and Voicebank's symbols do not match, you can try to download a plugin that can convert romaji to hiragana, which will help change the notes to something your voicebank can read. Adding plugins to Utau is just like adding voicebanks, you just put them into the plugins folder instead of the voice folder.

Does your ust have any extra symbols after the lyrics, such as 囁 or _弱? (some have underscores, some do not). These are called appends, and are extra voicebanks that some Utauloids have recorded,. However, some will not have these banks and therefore cannot understand these symbols. If this is the case, click ctrl+a, then at the top of your screen click Tools, then Built in tools, then Suffix Broker. Leave the suffix broker blank, then click OK. This will clear any appends.

If this is not the case, maybe you could try fitting the UST to your voicebank? First, hit Ctrl+A to select all of you notes, right click on a note, and then hit Property. Once you see the menu pop up, make sure that STP is empty. Then, to the top right of your screen to the right of the MIDI buttons, you will see a variety of different options. Click these buttons in this order: Reset, P2P3. It might also help to hit ACPT which will reset the envelopes. That should help fit your voicebank.

You might have to do multiple of these things to get it to work.
 
Last edited:
  • Like
Reactions: rainydaze

rainydaze

Momo's Minion
Thread starter
If you are absolutely sure that your UST and voicebank are of the same type, then these are the only things I could think of at the moment:

What language is your UST in? If you UST uses romaji and your voicebank can only read Hiragana, or vica versa, your Utau won't be able to read it and therefore won't make any sound. To check what language your voicebank can read, you can go into their voice files. If your voicebank's wav files are titled with symbols like "あ", or "か", that is hiragana. If the tiles are more like "a" or "ka", that is romaji. If your UST and Voicebank's symbols do not match, you can try to download a plugin that can convert romaji to hiragana, which will help change the notes to something your voicebank can read. Adding plugins to Utau is just like adding voicebanks, you just put them into the plugins folder instead of the voice folder.

Does your ust have any extra symbols after the lyrics, such as 囁 or _弱? (some have underscores, some do not). These are called appends, and are extra voicebanks that some Utauloids have recorded,. However, some will not have these banks and therefore cannot understand these symbols. If this is the case, click ctrl+a, then at the top of your screen click Tools, then Built in tools, then Suffix Broker. Leave the suffix broker blank, then click OK. This will clear any appends.

If this is not the case, maybe you could try fitting the UST to your voicebank? First, hit Ctrl+A to select all of you notes, right click on a note, and then hit Property. Once you see the menu pop up, make sure that STP is empty. Then, to the top right of your screen to the right of the MIDI buttons, you will see a variety of different options. Click these buttons in this order: Reset, P2P3. It might also help to hit ACPT which will reset the envelopes. That should help fit your voicebank.

You might have to do multiple of these things to get it to work.
I couldn't get it to work unfortunately. To give you some more info, I re-installed utau and re-downloaded all utau related files (VBs, plugins etc) because I didn't change my locale to japan when I first installed it. The USTs worked fine before re-installing by the way.
 

Ibis

Momo's Minion
Have you tried using your voicebanks outside of your USTs after re-installing UTAU? Also, did you install it any differently than you did before (besides changing your locale)? Maybe you could try re-downloading the USTS as well, though I'm not sure how much of a difference that would make.
 
Last edited:

rainydaze

Momo's Minion
Thread starter
Have you tried using your voicebanks outside of your USTs after re-installing UTAU? Also, did you install it any differently than you did before (besides changing your locale)? Maybe you could try re-downloading the USTS as well, though I'm not sure how much of a difference that would make.
I re-installed utau and the USTs and now when I try to open an UST a pop up appears on the screen saying "the file name or number is invalid" in japanese :-(

update: I managed to open an UST but it's not making any sound. The VBs work fine outside USTs.
 
Last edited:

Ibis

Momo's Minion
When you go into project properties, is the text red in the box labeled "Tool 2 Resample" near the bottom? If so, that means you don't have the folder that holds all of the voice files (this file is usually generated by UTAU whenever you make a UST, but some shared USTs that I have found do not include it). Don't fret, usually all you have to do to fix this is check the box underneath that that says "Use resampler.dll (Setting isn't saved to project)"

If this is not the case, and you do in fact have a folder containing the voice files as well as the UST, could I have some screenshots of the UST open in UTAU to try and rule out any other problems?
 
  • Like
Reactions: rainydaze

rainydaze

Momo's Minion
Thread starter
When you go into project properties, is the text red in the box labeled "Tool 2 Resample" near the bottom? If so, that means you don't have the folder that holds all of the voice files (this file is usually generated by UTAU whenever you make a UST, but some shared USTs that I have found do not include it). Don't fret, usually all you have to do to fix this is check the box underneath that that says "Use resampler.dll (Setting isn't saved to project)"

If this is not the case, and you do in fact have a folder containing the voice files as well as the UST, could I have some screenshots of the UST open in UTAU to try and rule out any other problems?
I re-installed utau again a few moments ago. Now it does sing, but some notes are quieter than others, and some are completely silent.
화면 캡처 2022-07-27 104524.png

here's the link to the ust in the pic by the way if you need it . I just tried a different ust , and it sings all the notes but the timing is odd in some regions.


update: I followed this tutorial (timestamp 4:21) on the tokyo teddy bear ust's and managed to fix the timing! But for the rolling girl ust it still doesn't sing some notes. Maybe the ust could be the issue?​

 
Last edited:

Ibis

Momo's Minion
You need help with Yokune Ruko's voicebank? well, you called the right person.

I'm glad you could get it working! I think I know why some notes don't work for that UST. The Ruko voicebank you are using only has one pitch recorded (also reffered to as a monopitch bank), so they can't read the notes marked with G4 or any other pitches. All you have to do to fix that is highlight the notes labeled with G4 (or any other combination, such as B3), go into the suffix broker, leave the box blank, then hit okay. If you need more information about opening and using the suffix broker, I explained it more in depth in my first post while explaining appends. If that still doesn't work, I would say it's because they don't have certain notes recorded, meaning they can't sing them since there literally is no sound file to play. Though from my experience, Yokune Ruko's voicebanks are usually pretty good about including everything, so I wouldn't think that would be it.

Since you're using Ruko's normal VCV bank and not their KIRE bank, I wouldn't think the quieter notes wouldn't have anything to do with the voicebank itself, so I would try raising the intensity. See that little number above each note? That's the intensity. If you put your cursor next to the number, you should see a vertical line with an arrow on the top and bottom. Dragging upwards will raise the intensity (make it louder) or lower it (make it quieter). The notes labeled 息 are at 25, which is a lower intensity than the rest of the notes that are at 100.

My only suggestion now would be to fit the UST to your Utauloid (in this case, Yokune Ruko), which I explained how to do in a previous post. Fitting your UST to your Utauloid will basically reset the parameters and replace them to best fit whoever you are using. It's a pretty important thing to know how to do when doing a cover. Might I suggest Yuunari's tutorial here?
 
Last edited:
  • Like
Reactions: rainydaze

rainydaze

Momo's Minion
Thread starter
You need help with Yokune Ruko's voicebank? well, you called the right person.

I'm glad you could get it working! I think I know why some notes don't work for that UST. The Ruko voicebank you are using only has one pitch recorded (also reffered to as a monopitch bank), so they can't read the notes marked with G4 or any other pitches. All you have to do to fix that is highlight the notes labeled with G4 (or any other combination, such as B3), go into the suffix broker, leave the box blank, then hit okay. If you need more information about opening and using the suffix broker, I explained it more in depth in my first post while explaining appends. If that still doesn't work, I would say it's because they don't have certain notes recorded, meaning they can't sing them since there literally is no sound file to play. Though from my experience, Yokune Ruko's voicebanks are usually pretty good about including everything, so I wouldn't think that would be it.

Since you're using Ruko's normal VCV bank and not their KIRE bank, I wouldn't think the quieter notes wouldn't have anything to do with the voicebank itself, so I would try raising the intensity. See that little number above each note? That's the intensity. If you put your cursor next to the number, you should see a vertical line with an arrow on the top and bottom. Dragging upwards will raise the intensity (make it louder) or lower it (make it quieter). The notes labeled 息 are at 25, which is a lower intensity than the rest of the notes that are at 100.

My only suggestion now would be to fit the UST to your Utauloid (in this case, Yokune Ruko), which I explained how to do in a previous post. Fitting your UST to your Utauloid will basically reset the parameters and replace them to best fit whoever you are using. It's a pretty important thing to know how to do when doing a cover. Might I suggest Yuunari's tutorial here?

Thank you so much. The USTs work fine now :-)
 

Similar threads